
R for Data Cleaning
What is R? 
A scripting language

Why use R? 
To reproduce &/or share workflows.

Reference: Courtesy of: J. Bayalis. (c) Field Museum of Natural History. 
https://mm.fieldmuseum.org/136227d2-e642-4952-b993-3fe7c434cdc2 (accessed on 29 Oct 2021)
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Introduction to R



What is this thing called “R”? 

R-Studio is: 

● an IDE — “integrated development 
environment” (a program that makes coding 
more convenient)

R is both: 

● a scripting language

● software to R-scripts

INTRODUCTION TO R

R & R-Studio are useful for: 

● making reproducible data-handling workflows

● sharing those workflows (as scripts & documentation)



INTRODUCTION TO RWhat Can/Can’t R Do?

R

Formulas

Charts & Graphs

Auto-formats fields Some functions

Allow creation of lookup lists

Allow character sets besides Latin1 (e.g., UTF-8)

Track changes after closing

Maintain integrity between rows and columns

Enforce referential integrity between different sheets Some assembly required



Useful Philosophy/ies
“All tidy data is alike; all messy data is messy in its own way.” – Hadley Wickham/Leo

Tidy data structure: 
(based on Codd 1990/normalization)

● 1 row = 1 observation (record)

● 1 column = 1 variable (attribute)

● 1 value = 1 observation of 1 variable

● 1 table = 1 type of observational unit [1 
record-type]

– e.g.— 1 table for locality 
records; 1 table taxon records

INTRODUCTION TO R



Useful Philosophy/ies
“All tidy data is alike; all messy data is messy in its own way.” – Hadley Wickham/Leo

 Messy data structure 

● 1 row != 1 observation (record)

● 1 column!= 1 variable (attribute)

● 1 value != 1 observation of 1 variable

● 1 table != 1 type of observational unit [1 
record-type]

– e.g.— 1 table for locality 
records; 1 table taxon records
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Useful Philosophy/ies
“All tidy data is alike; all messy data is messy in its own way.” – Hadley Wickham/Leo

 Messy data structure 

● 1 row != 1 observation (record)

● 1 column != 1 variable (attribute)

● 1 value != 1 observation of 1 variable

● 1 table != 1 type of observational unit [1 record-type]

– e.g.-- 1 table for locality records; 1 table 
taxon records

INTRODUCTION TO R

But Remember! Useful data
“Data cleaning is improving quality of 
data to make them ‘fit for use’”



The two actions are opposites:

1. Gathering: Adds rows to consolidate columns

Reshaping Data
Gathering and Spreading

INTRODUCTION TO R

Cat # ID-# ID

FM 15 ID-1 P. jagori

FM 15 ID-2 P. minor

FM 15 ID-3 P. vampyrus

FM 36 ID-1 R. inops

FM 36 ID-2 R. rufus

FM 36 ID-3 R. arcuatus

Cat # ID-1 ID-2 ID-3

FM 15 P. jagori P. minor P. vampyrus

FM 36 R. inops R. rufus R. arcuatus

1



The two actions are opposites:

1. Gathering: Adds rows to consolidate columns

2. Spreading: Adds columns to consolidate rows

Reshaping Data
Gathering and Spreading

INTRODUCTION TO R

Cat # ID-# ID

FM 15 ID-1 P. jagori

FM 15 ID-2 P. minor

FM 15 ID-3 P. vampyrus

FM 36 ID-1 R. inops

FM 36 ID-2 R. rufus

FM 36 ID-3 R. arcuatus

Cat # ID-1 ID-2 ID-3

FM 15 P. jagori P. minor P. vampyrus

FM 36 R. inops R. rufus R. arcuatus

Obj Meas. Value

jar height 36

jar width 21

jar depth 5

vase height 20

vase width 6

vase depth 4

Obj height width depth

jar 36 21 5

vase 20 6 4

1

2



Reshaping Data

Gathering & spreading are similar to what 
you can do with Pivot Tables (in 
Excel/similar spreadsheet-software)

– Except Pivot Tables tend to be 
unstable (especially with larger/more 
complex/memory-intensive datasets)

+ R stays stable

Split-Apply-Combine is a 
philosophy/phrase commonly referenced 
with R users  

● Break down code and datasets into 
only the pieces relevant for each step

● Similar to “faceting”, “querying” … other 
database platforms have other fancy 
names for it (map reduce?)

INTRODUCTION TO R



R-Studio Setup



R-Studio – Some Help…
You can trust CRAN — the “Comprehensive R Archive Network.”

Installation

● 1st – Install R

– cran.r-project.org 

R-STUDIO SETUP

● 2nd – Install R-Studio

– rstudio.com/products/rstudio/downlo
ad

Cheat Sheet: 

● Overview of what a package can do.

– rstudio.com/resources/cheatsheets

https://cran.r-project.org/
http://www.rstudio.com/products/rstudio/download
http://www.rstudio.com/products/rstudio/download
http://www.rstudio.com/resources/cheatsheets


R-Studio Setup

0) Double click the R-Studio icon to 
start the program. 

Make a new project: 

1) Go to File → New Project

R-STUDIO SETUP



R-Studio Setup

2) Choose “New directory” 
then choose “Empty project”

3) Name the new project directory 
Test, and save it to your 
Desktop.

After today, never save on 
Desktop!

4) Click “Create Project”

R-STUDIO SETUP



Opening a 
Script

5) In RStudio, 

 Go to File → New File → 
R-Script

R-STUDIO SETUP



Opening a 
Script

5) In RStudio, 

 Go to File → New File → 
R-Script

The new R script will open in the 
Source Editor pane (upper left):

R-STUDIO SETUP



Opening a 
Script

R-STUDIO SETUP

My eyes are on fire! is 
there a way to change 
Script Editor background 
from white to a darker 
color?  

Go to Tools -> Global 
Options -> Appearance 
-> choose a theme.
   (“Merbivore Soft” is 
easy on the eyes)



Source Editor pane

1.   = edit/save scripts

Console pane

2.   = run scripts

Environment

3.   = see objects

Help = help!

4. - Google...

5. - Stackoverflow...

R-Studio 
Interface

R-STUDIO SETUP

Source Editor pane
(edit a script)

Console pane
(run a script)

Environment
variables, history

File Browser 
& Help



More details here:

1. https://github.com/rstudio/cheatsheet

s/blob/master/source/pdfs/rstudio-ID

E-cheatsheet.pdf. 

R-Studio 
Interface

R-STUDIO SETUP

Source Editor pane
(edit a script)

Console pane
(run a script)

Environment
variables, history

File Browser 
& Help

https://github.com/rstudio/cheatsheets/blob/master/source/pdfs/rstudio-IDE-cheatsheet.pdf
https://github.com/rstudio/cheatsheets/blob/master/source/pdfs/rstudio-IDE-cheatsheet.pdf
https://github.com/rstudio/cheatsheets/blob/master/source/pdfs/rstudio-IDE-cheatsheet.pdf


Mapping and Planning

Find your functions & their corresponding 
packages:

● Google “R how to [sort by one column, 
add rows, etc]”

● In R Studio, search by name for 
packages/functions in the Help panel.

Do your mapping & planning steps!  

Specifically:

● Map - which fields map directly to 
where they go?

● Plan - which fields need to be 
split/combined/reshaped?

R-STUDIO SETUP



A little more 
R-Studio Setup

In the Help/Files pane (lower right), 
● 6) click the “Files” tab:

○ add a folder named 
data01raw

○ and a folder named 
data02processed

● 7) Outside of RStudio, download 
WorkshopData.csv, and move 
the file to the data01raw folder 
inside your project directory..

R-STUDIO SETUP



Script Setup



SCRIPT SETUPScript Setup (& some R syntax)
R-scripts are text files with a “.R” extension, and [hopefully] working code inside:

Objects Functions  Arguments      #Comments
(nouns) (verbs)

 column123 <- c(93,13,42)

# creates a numeric vector called column123

Arguments and their 
options modify what 
a function does



SCRIPT SETUPScript Setup (& some R syntax)
R-scripts are text files with a “.R” extension, and [hopefully] working code inside:

Objects  [nouns]: column123

- data structures:  Vectors, Data Frames (also: Lists, Data tables...)
- data types:       Numeric, Character, Factor, Integer, Logical, NA

Functions  [verbs]: c()  

# The function “c()” combines values into a vector

- There are many built-in functions in the “base” package.
- More can be added by installing extra packages.



Comment out lines (or parts of lines) with 
“#”

Tips on making objects:

● Be consistent with:

- meaningful & concise names, e.g.: 
"day_1" (not 
"first_day_of_the_month" or "djm1")

- formatting & spacing

Defining some terms: 

● A data frame is a table

●  A vector is a field/column

● “A package is a collection of R 
functions, data and compiled code”

● “The location where the packages are 
stored is called the library”

SCRIPT SETUPScript Setup (& some R syntax)
R-scripts are text files with a “.R” extension, and [hopefully] working code inside:

Reference: 
https://stackoverflow.com/questions/26900228/what-is-the-difference-between-a-library-and-a-package-in-r#:~:text=In%20R%2C%20a%20package%20is%20a%20collection%20of,and%20it%2
0will%20be%20stored%20in%20your%20library.



SCRIPT SETUPScript Setup (& some R syntax)
R-scripts are text files with a “.R” extension, and [hopefully] working code inside:

Formatting in R is very forgiving -- spaces and line breaks won’t affect how functions are 
executed

- BUT be careful -- easy to get messy...

Consider following one of these style guides:
- http://adv-r.had.co.nz/Style.html 
- https://google.github.io/styleguide/Rguide.xml 
- http://jef.works/R-style-guide/

http://adv-r.had.co.nz/Style.html
https://google.github.io/styleguide/Rguide.xml
http://jef.works/R-style-guide/


The first 4 lines of your script should always be 

comments (#):

1. The script’s purpose

2. R version

3. Your EMu user name

4. The date

Basics
Step 2

SCRIPT SETUP

1 # Workshop script for cleaning messy data.

2 # R version 3.4.0 (2017-04-21)

3 # KWebbink

4 # 16-Aug-2017

5  

6  

7  

8  



Install and load “tidyr” package.

Basics
Step 3

SCRIPT SETUP

1 # Workshop script for cleaning messy data.

2 # R version 3.4.0 (2017-04-21)

3 # KWebbink

4 # 16-Aug-2017

5  

6 install.packages("tidyr")

7 library("tidyr")

8  



Basics
Step 4

SCRIPT SETUP

1 # Workshop script for cleaning messy data.

2 # R version 3.4.0 (2017-04-21)

3 # KWebbink

4 # 16-Aug-2017

5  

6 install.packages("tidyr")

7 library("tidyr")

8  

9 # Input data-files will go here:

10 setwd(“C:/path/to/project/data”)

Set the working directory with setwd().

● On Windows systems, a standard DOS file 

path begins with volume or drive letter, C: for 

the local disk.

● In macOS, you may omit the local disk or use 

~, which is shorthand for the home directory.



Basics
Step 5

SCRIPT SETUP

1 # Workshop script for cleaning messy data.

2 # R version 3.4.0 (2017-04-21)

3 # KWebbink

4 # 16-Aug-2017

5  

6 install.packages("tidyr")

7 library("tidyr")

8  

9 # Input data-files will go here:

10 setwd(“C:/path/to/project/data”)

Save your script by pressing Ctrl+S.

● It will appear as a “.R” text file inside your 

project directory.



Executing 
Commands
Step 6

SCRIPT SETUP

1 # Workshop script for cleaning messy data.

2 # R version 3.4.0 (2017-04-21)

3 # KWebbink

4 # 16-Aug-2017

5  

6 install.packages("tidyr")

7 library("tidyr")

8  

9 # Input data-files will go here:

10 setwd(“C:/path/to/project/data”)
Run/Execute parts of your script by:

●  Highlighting the text

● And pressing Ctrl+Enter (or in 

macOS, ⌘+Return)

Executed code will show in the Console 

pane (lower left).

When R is ready to run more code, a new 

“>” prompt will appear:

> # Workshop script for cleaning messy data.

>

> install.packages(“tidyr”)

> library(“tidyr”)

>

> # Input/Output data-files will go here:

> setwd(“C:/path/to/project/data”)

>



Executing 
Commands
Step 7

SCRIPT SETUP

In the Console pane, check your working 

directory by entering getwd() and hitting Enter.

> install.packages(“tidyr”)

> library(“tidyr”)

>

> # Input/Output data-files will go here:

> setwd(“C:/path/to/project/data”)

> getwd()

[1] “C:/path/to/project/directory”

>



Importing 
and Viewing Data



Importing Data 
Into R

IMPORTING AND VIEWING DATA

9 # Input/Output data-files will go here:

10 setwd(“C:/path/to/project/data”)

11  

12 raw_data <- read.csv(“WorkshopDataset.csv”,

13                       stringsAsFactors = F)

1) Import WorkshopDataset.csv with the 

function read.csv()

2) Run line 12-13 (by highlighting them & 

pressing Ctrl+Enter)

 …The Environment pane will show 

information about the objects.

3) Click raw_data for a summary:



4. NOTE: In R, the data frame rawLoans…

○ is a copy of 01loans.csv held 

in your computer’s RAM.

○ is not a live view of the file 

“01loans.csv”

Importing Data 
Into R

IMPORTING AND VIEWING DATA

CSV

01loans.csv

editing rawLoans … is NOT … editing 01loans.csv



IMPORTING AND VIEWING DATASummarizing in the dataframe preview
Note: Sorting/filtering the data preview does not edit the actual dataframe.

Click Filter to 
filter by values in 
a single column.

Enter a value in 
the search bar to 
find records with 
that value in any 
field.

Click the 
sort-icons to sort 
by a column.



Reshaping Data



Reshaping data with gather() & spread()

spread() is similar to what often needs 
to be done with long datasets, where 
records have multiple rows to allow 
multiple values of the same attribute

– e.g., multiple rows for one catalog 
record’s giant list of multi-value 
notes.

gather() is similar to what often needs 
to be done with wide datasets, where 
multiple columns exist for the same 
attribute/type of value, and they need to 
be gathered into a single column.

RESHAPING DATA



gather()

RESHAPING DATA

7 setwd(“C:/path/to/project/data”)

8  

9 rawLoans <- read.csv(“01loans.csv”)

10  

11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     value = “Objects”,

14                     2:6)

1. Gather (or “melt”) rawLoans to 
make 1 column for “Loan #”, & 1 
column for “Objects”.



1. Gather (or “melt”) rawLoans to make 1 column for “Loan #”, & 1 column 
for “Objects”.

gather() takes some arguments:

– key = a new single column for the old column-names.

– value = a new single column for the corresponding old 
column-values.

– x:y = a range of selected columns (by name or index #) to gather.

gather()

RESHAPING DATA

7 setwd(“C:/path/to/project/data”)

8  

9 rawLoans <- read.csv(“01loans.csv”)

10  

11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     value = “Objects”,

14                     2:6)



gather()

RESHAPING DATA

7 setwd(“C:/path/to/project/data”)

8  

9 rawLoans <- read.csv(“01loans.csv”)

10  

11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     value = “Objects”,

14                     2:6)

1. Gather (or “melt”) rawLoans to 
make 1 column for “Loan #”, & 1 
column for “Objects”.

2. Run/execute lines 11-14 by:

–  Highlighting the lines.

–  And pressing Ctrl+Enter



RESHAPING DATA

gather()

11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     value = “Objects”,

14                     2:6)



11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     value = “Objects”,

14                     2:6)

RESHAPING DATA

gather()



11 tidyLoans <- gather(rawLoans,

12                     key = “ObjKey”,

13                     2:6)

14  

15  

16  # Drop the ObjKey column by subsetting: 

17  tidyLoans2 <- tidyLoans [,2]

subsetting [ ]

RESHAPING DATA

1. Gather (or “melt”) rawLoans to 
make 1 column for “Loan #”, & 1 
column for “Objects”.

If we don’t want the ObjKey
column in the new dataframe: 

2. Subset tidyLoans with lines 
16-17 
(tidyLoans[row,column])



RESHAPING DATA

● tidyLoans[tidyLoans$
Loan==2,]
- # returns rows where 

“Loan” = “2”

● tidyLoans[1,3]
- # returns the value in 

row 1, column 3

● tidyLoans[1,]
- # returns row 1 (all 

values)

● tidyLoans[,-3]
- # removes column 3 

(all values)

● tidyLoans$Loan
- # returns all values in 

“Loan” column

● tidyLoans$Loan[2]
- # returns 2nd value 

in “Loan” column

subsetting [ ] 

In dataframes: rows, columns, and values can be referenced by subsetting:

by numeric index by $name by logical condition



Exporting Data



EXPORTING DATA

1. Export tidyLoans2 with the 
function write.csv().

2. Run/execute lines 18-19 by:

–  Highlighting the lines.

–  And pressing Ctrl+Enter

Exporting Data
15 # Drop the ObjKey column by subsetting:

16 tidyLoans2 <- tidyLoans[,-2]

17  

18 write.csv(tidyLoans2,

19           file = “tidy.csv”)



EXPORTING DATA

1. Export tidyLoans2 with the 
function write.csv().

2. Run/execute lines 18-19 by:

–  Highlighting the lines.

–  And pressing Ctrl+Enter

Exporting Data
15 # Drop the ObjKey column by subsetting:

16 tidyLoans2 <- tidyLoans[,-2]

17  

18 write.csv(tidyLoans2,

19           file = “tidy.csv”)

3. Open up “tidy.csv” in Excel…

– Text

–  Text



EXPORTING DATA

1. Export tidyLoans2 with the 
function write.csv().

2. Run/execute lines 18-19 by:

–  Highlighting the lines.

–  And pressing Ctrl+Enter

Exporting Data

3. Open up “tidy.csv” in Excel…

– Is it mangled?

– Try setting the argument 
“row.names” to “FALSE”:

15 # Drop the ObjKey column by subsetting:

16 tidyLoans2 <- tidyLoans[,-2]

17  

18 write.csv(tidyLoans2,

19           file = “tidy.csv”,

19           row.names = F)



Extras



Some other functions to try… 
Get summaries of columns

summary(rawLoans)

EXTRAS

> summary(rawData)

Cat..Numb.         University             Collector     

UWP:122471: 2   Univ of Guatemala:760     Vargas I   : 207

UWP:157339: 2                             Betancur J : 203  

UWP:100217: 1                             Callejas R : 48



Some other functions to try… 

gsub(“\\s+”,
 “ ”,
 rawLoans$Loans)

EXTRAS

Use regular expressions:

# replace multiple spaces…
# …with a single space…
# …in this column.



Some other functions to try… 

setwd(“path/to/script-folder”)
source(“script.R”)

EXTRAS

Run an R script in R-Studio:

# output objects will show 
in Environment pane



Git
And now for something 
[slightly] different:

EXTRAS



Git
What is this thing called 
git? 

● Git: a way to share and track 
changes in code (or any digital 
content stored in a file or 
directory) control

– If (when) you break your 
code, you can use git to 
retrieve (pull) a previously 
saved (pushed) version.

● Github.com & Bitbucket.com

– Online code repositories that 
use git.

– Users can share 
(fork/branch) code.

EXTRAS



EXTRAS

Other R Courses/Resources: 

● Roger Peng / Johns Hopkins
- class: r-programming
- blog: SimplyStatistics.org

● Data Carpentry / R for 
Ecology

– datacarpentry.org/R-ecol
ogy-lesson/

Installation

● 1st – Install R
- cran.r-project.org

● 2nd – Install R-Studio
- rstudio.com/products/

rstudio/download

For more help: 

● R-Studio’s built-in help

● www.rOpenSci.org 

● RStudio.com/resources/
cheatsheets

R-Studio – More Help…

http://www.coursera.org/learn/r-programming
http://simplystatistics.org
https://datacarpentry.org/R-ecology-lesson/
https://datacarpentry.org/R-ecology-lesson/
https://cran.r-project.org/
http://www.rstudio.com/products/rstudio/download
http://www.rstudio.com/products/rstudio/download
http://www.ropensci.org
http://rstudio.com/resources/cheatsheets
http://rstudio.com/resources/cheatsheets
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